<!DOCTYPE html>
<html lang="en-CA">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no" /><meta property="og:image" content="//oliverdailynews.com/fbDefault.jpg" />
<title>When is this &#8220;foolishness&#8221; going to end</title>
<meta name='robots' content='max-image-preview:large' />

			<style type="text/css">
				.slide-excerpt { width: 100%; }
				.slide-excerpt { top: 0; }
				.slide-excerpt { left: 0; }
				.flexslider { max-width: 1280px; max-height: 270px; }
				.slide-image { max-height: 270px; }
			</style>
			<style type="text/css">
				@media only screen
				and (min-device-width : 320px)
				and (max-device-width : 480px) {
					.slide-excerpt { display: none !important; }
				}
			</style> <link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Oliver Daily News &raquo; Feed" href="https://oliverdailynews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oliver Daily News &raquo; Comments Feed" href="https://oliverdailynews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Oliver Daily News &raquo; When is this &#8220;foolishness&#8221; going to end Comments Feed" href="https://oliverdailynews.com/when-is-this-foolishness-going-to-end/feed/" />
<link rel="canonical" href="https://oliverdailynews.com/when-is-this-foolishness-going-to-end/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/oliverdailynews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='news-pro-theme-css'  href='https://oliverdailynews.com/wp-content/themes/news-pro/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://oliverdailynews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://oliverdailynews.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.6' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 8px;
	line-height: 10px;
	height: 10px;
	background-image: url('https://oliverdailynews.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='dashicons-css'  href='https://oliverdailynews.com/wp-includes/css/dashicons.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700%7CPathway+Gothic+One&#038;ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='https://oliverdailynews.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='slider_styles-css'  href='https://oliverdailynews.com/wp-content/plugins/genesis-responsive-slider/assets/style.css?ver=1.0.1' type='text/css' media='all' />
<script type='text/javascript' src='https://oliverdailynews.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://oliverdailynews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://oliverdailynews.com/wp-content/themes/news-pro/js/responsive-menu.js?ver=1.0.0' id='news-responsive-menu-js'></script>
<script type='text/javascript' src='https://oliverdailynews.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21' id='svg-x-use-js'></script>
<link rel="https://api.w.org/" href="https://oliverdailynews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://oliverdailynews.com/wp-json/wp/v2/posts/221193" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://oliverdailynews.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="https://oliverdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Foliverdailynews.com%2Fwhen-is-this-foolishness-going-to-end%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://oliverdailynews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Foliverdailynews.com%2Fwhen-is-this-foolishness-going-to-end%2F&#038;format=xml" />
<link rel="apple-touch-icon" href="//oliverdailynews.com/apple-touch-icon.png" /><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-25913439-54', 'auto');
  ga('send', 'pageview');

</script>
<!-- Global site tag (gtag.js) - Google Analytics Added June 16, 2018 New implementation. In Shawn Limbach's google account-->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-120967638-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-120967638-1');
</script>
<!--[if IE 8]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #006989; }
</style>
	<style>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</style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-221193 single-format-standard custom-background sidebar-content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden news-pro-blue responsive-menu-slide-left" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-custom" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-106043" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-106043"><a href="https://oliverdailynews.com/#recent-comments-3" itemprop="url"><span itemprop="name">Recent Comments</span></a></li>
<li id="menu-item-138586" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-138586"><a href="https://oliverdailynews.com/#recent-posts-3" itemprop="url"><span itemprop="name">Current Posts</span></a></li>
<li class="right search"><form class="search-form" method="get" action="https://oliverdailynews.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search ODN" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://oliverdailynews.com/?s={s}" itemprop="target"></form></li></ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><aside class="header-left widget-area header-widget-area"><section id="simple-social-icons-2" class="widget simple-social-icons"><div class="widget-wrap"><ul class="aligncenter"><li class="ssi-email"><a href="mailto:oliverdailynews@gmail.com" ><svg role="img" class="social-email" aria-labelledby="social-email-2"><title id="social-email-2">Email</title><use xlink:href="https://oliverdailynews.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-email"></use></svg></a></li><li class="ssi-facebook"><a href="https://www.facebook.com/oliverdailynews" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-facebook" aria-labelledby="social-facebook-2"><title id="social-facebook-2">Facebook</title><use xlink:href="https://oliverdailynews.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-facebook"></use></svg></a></li><li class="ssi-rss"><a href="https://oliverdailynews.com/feed" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-rss" aria-labelledby="social-rss-2"><title id="social-rss-2">RSS</title><use xlink:href="https://oliverdailynews.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/oliverDailynews" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-2"><title id="social-twitter-2">Twitter</title><use xlink:href="https://oliverdailynews.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section>
<section id="text-230" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Admin Login</h4>
			<div class="textwidget"><a href="https://oliverdailynews.com/wp-admin">Admin Login</a></div>
		</div></section>
</aside><aside class="header-middle widget-area header-widget-area"><section id="text-228" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><h1 style="font-size:42px;">oliver <span style="color:#27a3d1;;">Daily</span> news</h1>
Serving the Southern Okanagan</div>
		</div></section>
</aside><aside class="widget-area header-widget-area"><section id="text-340" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><a href="http://www.pappasfirehallbistro.ca/"><img src="https://oliverdailynews.com/biz-page-2/fotis4square.jpg" alt="bistro" /></a></p>
</div>
		</div></section>
</aside></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-primary" class="menu genesis-nav-menu menu-primary"><li id="menu-item-102065" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-102065"><a href="https://oliverdailynews.com/" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-102557" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102557"><a href="https://oliverdailynews.com/bcnews/" itemprop="url"><span itemprop="name">BC Press Releases</span></a></li>
<li id="menu-item-102561" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-102561"><a href="https://oliverdailynews.com/cbc-news/" itemprop="url"><span itemprop="name">CBC Top Stories</span></a></li>
<li id="menu-item-104460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-104460"><a href="https://oliverdailynews.com/classifieds/browse-categories/" itemprop="url"><span itemprop="name">Free CLASSIFIEDS</span></a></li>
<li class="right date">July 2, 2021</li></ul></div></nav><div id="home-featured"><div class="wrap"><div class="home-slider widget-area"><section id="genesisresponsiveslider-widget-2" class="widget genesis_responsive_slider"><div class="widget-wrap">
		<div id="genesis-responsive-slider">
			<div class="flexslider">
				<ul class="slides">
					
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/07/apex-make-a-copy-2-ban-1280x270.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/06/ban-yellow-and-white-123-1280x270.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/06/apex-cat-234-1280x270.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/06/ban-bush-123.jpg" alt="ban bush" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/06/ban-red-cacti-123-1280x270.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/06/ban-hill-123.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/06/red-and-yellow-123-1280x270.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/fairview-view-ban.jpg" alt="fairview view" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/prison-123-1280x270.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/ban-bird-snow-cliffs-123-1280x270.jpg" alt="ban bird" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/apex-cars-123.jpg" alt="slice cars" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/apex-ban-tuck-123.jpg" alt="tuck ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/apex-green-banner-123.jpg" alt="green ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/apex-banner-eby-123-1280x270.jpg" alt="eby ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/apex-road-22-c-123-banner-1280x270.jpg" alt="ban rd 22" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/05/apex-pink-banner-123-1280x270.jpg" alt="pink banner" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/bird-banner-123-1280x270.jpg" alt="bird banner" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/banner-pipe-123-1280x270.jpg" alt="ban pipe" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/banna-white-1280x270.jpg" alt="banna white" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/chat-banner-123-1280x270.jpg" alt="chat banner" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/bam-armstrong-123-1263x270.jpg" alt="ban armstrong" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/banner-cotter-123-1274x270.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/apex-where-123-ban-1280x270.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/edwin-frost-banner-123.jpg" alt="ban" />
														</div><!-- end .slide-image -->

					</li>
				
					<li>

						
						<div class="slide-image">
														<img src="https://oliverdailynews.com/wp-content/uploads/2021/04/storm-banner-123-1276x270.jpg" alt="storm banner" />
														</div><!-- end .slide-image -->

					</li>
								</ul><!-- end ul.slides -->
			</div><!-- end .flexslider -->
		</div><!-- end #genesis-responsive-slider -->

		</div></section>
</div></div></div><div class="site-inner"><div id="top"></div><div class="content-sidebar-wrap"><main class="content"><article class="post-221193 post type-post status-publish format-standard category-news entry" aria-label="When is this &#8220;foolishness&#8221; going to end" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">When is this &#8220;foolishness&#8221; going to end</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2021-07-02T11:31:47-07:00">July 2, 2021</time>, <time class="entry-time" itemprop="datePublished" datetime="2021-07-02T11:31:47-07:00">11:31 am</time></p></header><div class="entry-content" itemprop="text"><p><strong>Victoria BC</strong> &#8211; Protesters pulled down a statue of Capt. James Cook and threw the pieces into Victoria’s Inner Harbour on Thursday night.</p>
<p>The statue of the British explorer, which stood in front of the Empress Hotel, was destroyed shortly after 8:30 p.m.</p>
<p><strong>Winnipeg, Manitoba</strong> &#8212; Demonstrators toppled statues of Queen Elizabeth II and Queen Victoria at the Manitoba Legislature on Thursday afternoon.</p>
<p>The statues were taken down during events held at the Manitoba Legislature grounds in honour of the Indigenous children who died at former residential schools.</p>
<p>The statue of Queen Victoria was coated in red paint and the base covered in red handprints.</p>
<p>This statue was first unveiled on the grounds in 1904.</p>
<p>How many churches burned down in BC ? Four locally in SOS</p>
<p>This was done by :</p>
<ol>
<li>Opportunistic oppressors and settlers or indigenous warriors</li>
</ol>
<p>What do native, band and indigenous leaders say ?</p>
<p><strong>Chief of LSIB</strong></p>
<p>Chief Keith Crow of the Lower Similkameen Indian Band said the fires have only compounded the pain of residential school survivors who are hurting.</p>
<p>Community members across the street from Our Lady of Lourdes Church, on the Chopaka Native Reserve, spotted a vehicle outside, went out to to investigate and saw the fire start. Crow said he arrived at the church about 15 minutes later, before the Fire Department.</p>
<p>“If the community came to us and said we want to remove the churches, we would have done it — in a good way. But for one individual to go and do this without community consensus — it’s heartbreaking for the ones that utilize the church.&#8221;</p>
<p><strong>Chief of PIB</strong></p>
<p>&#8220;I attended that school myself, the Indian day school. Even though it wasn&#8217;t as traumatic as the residential school, we still suffered the abuse to some extent from the priests and the nuns,&#8221; Greg Gabriel states</p>
<p>Children at the day school also attended religious services at the church ( Sacred Heart Catholic Church ),,,,,,, &#8220;Having said all that, there was a lot of community members today, especially the elderly ones who were saddened by the loss of this church because there were so many memories that were generated over the years — their children&#8217;s baptism, their grandchildren&#8217;s baptism,&#8221; Gabriel said.</p>
<p>&#8220;There&#8217;s mixed feelings throughout the community on the loss of this church.&#8221;</p>
<p><strong>OIB Chief</strong></p>
<p>A prominent Indigenous leader in the B.C. Southern Interior is condemning the acts of possible arson after four Catholic churches burnt down on First Nations land in six days.</p>
<p>Chief Clarence Louie of the Osoyoos Indian Band, who is also the tribal chair and spokesperson of the Okanagan Nation Alliance, said there is no doubt in his mind the fires were intentionally set.</p>
<p>“I wouldn’t call it suspicious, I’d call it what it is, it’s a criminal act, it’s vandalism. It’s arson.</p>
<p>***</p>
<p>&nbsp;</p>
<p>Let us not forget what has sparked the outrage &#8211; unreported deaths of children at residential schools.</p>
<p>But to quote Band and Indigenous Leaders &#8211; one crime does not relate to another.</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-comments-link"><a href="https://oliverdailynews.com/when-is-this-foolishness-going-to-end/#respond">Leave a Comment</a></span></p></footer></article>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/when-is-this-foolishness-going-to-end/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://oliverdailynews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name (First and last required)</label><span class="required">*</span><input id="author" name="author" type="text" value="" size="25" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email</label><span class="required">*</span><input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='221193' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form>	</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="text-263" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Ace</h4>
			<div class="textwidget">

<a href="
https://www.ace-canada.ca/en/store/ace-building-centre-oliver">
<img src="https://oliverdailynews.com/biz-page-2/ace22.jpg" alt="ace">
</a>

</div>
		</div></section>
<section id="text-294" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">So photos</h4>
			<div class="textwidget"><a href="
https://www.southokanaganphotos.today">
<img src="https://oliverdailynews.com/biz-page-2/so photo small.jpg" alt="so photos">
</a></div>
		</div></section>
<section id="text-291" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">paul petersen</h4>
			<div class="textwidget"><a href="
http://www.petersenconstruction.ca/index.htm">
<img src="https://oliverdailynews.com/biz-page-2/petersen.jpg" alt="petersen">
</a></div>
		</div></section>
<section id="text-279" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">alan</h4>
			<div class="textwidget"><a href="http://www.czepillaw.ca/index.html">
<img src="https://oliverdailynews.com/biz-page-2/alanbutton.jpg" alt="alan">
</a></div>
		</div></section>
<section id="text-255" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">cbc link</h4>
			<div class="textwidget"><a href="
http://www.cbc.ca/cmlink/rss-canada-britishcolumbia">
<img src="https://oliverdailynews.com/biz-page-2/cbclogo.jpg" alt="cbclogo">
</a>

</div>
		</div></section>
<section id="text-345" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">strike</h4>
			<div class="textwidget"><p><a href=" http://www.strikealarms.ca/"><br />
<img src="https://oliverdailynews.com/biz-page-2/strike.jpg" alt="strike" /><br />
</a></p>
</div>
		</div></section>
<section id="text-283" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">plante</h4>
			<div class="textwidget"><a href="https://oliverdailynews.com/biz-page-2/plantetwo.pdf">
<img src="https://oliverdailynews.com/biz-page-2/plante.jpg" alt="plante">
</a>



</div>
		</div></section>
<section id="text-334" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">quail</h4>
			<div class="textwidget"><p><a href=" http://www.quailsecurity.ca/"><br />
<img src="https://oliverdailynews.com/biz-page-2/quack2.jpg" alt="quail" /><br />
</a></p>
</div>
		</div></section>
<section id="text-182" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">PRJ Contracting</h4>
			<div class="textwidget"><a href="http://www.pjrcontracting.ca">
<img src="https://oliverdailynews.com/biz-page-2/pjrbutton.jpg" alt="pjr contracting">
</a>
</div>
		</div></section>
<section id="text-198" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Edward Jones</h4>
			<div class="textwidget"><a href="https://www.edwardjones.ca/financial-advisor/index.html?CIRN=101501">
<img src="https://oliverdailynews.com/biz-page-2/edjones.jpg" alt="edward jones">
</a></div>
		</div></section>
<section id="text-350" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">superior</h4>
			<div class="textwidget"><p><a href="http://www.superiortradesservices.com"><br />
<img src="https://oliverdailynews.com/biz-page-2/superiorbutton.jpg" alt="gerards" /><br />
</a></p>
</div>
		</div></section>
<section id="text-77" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Oliver Ready Mix</h4>
			<div class="textwidget"><a href="
http://www.oliverreadymix.com">
<img src="https://oliverdailynews.com/biz-page-2/oliverready22.jpg" alt="oliver ready mix">
</a>

</div>
		</div></section>
<section id="text-92" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Oliver Country Wines</h4>
			<div class="textwidget"><a href="http://www.olivercountrywines.ca">
<img src="https://oliverdailynews.com/biz-page-2/margbutton22.jpg" alt="oliver country wines">
</a>
</div>
		</div></section>
<section id="text-254" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">argon revised</h4>
			<div class="textwidget"><a href="
http://www.argonelectrical.ca">
<img src="https://www.oliverdailynews.com/biz-page-2/argonsnew.jpg" alt="argon">
</a></div>
		</div></section>
<section id="text-349" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">block</h4>
			<div class="textwidget"><p><a href="
https://oliverdailynews.com/biz-page-2/logoblock2.pdf"><br />
<img src="https://oliverdailynews.com/biz-page-2/logoblock1.jpg" alt="h and r block" /><br />
</a></p>
</div>
		</div></section>
<section id="custom_html-3" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><h4 class="widget-title widgettitle">3 bar</h4>
<div class="textwidget custom-html-widget"><a href="https://www.3barconstruction.com/"><img src="https://www.oliverdailynews.com/biz-page-2/phoebe22.jpg" alt="3 bar construction" ></a></div></div></section>
<section id="text-338" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Valley Storage</h4>
			<div class="textwidget"><p><a href=" https://www.valleystorageokanagan.com"><br />
<img src="https://oliverdailynews.com/biz-page-2/valley but 22.jpg" alt="valley" /><br />
</a></p>
</div>
		</div></section>
<section id="text-341" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">underground</h4>
			<div class="textwidget"><p><a href=" http://www.okanaganundergroundservices.ca/"><br />
<img src="https://oliverdailynews.com/biz-page-2/underground.jpg" alt="okanagan" /><br />
</a></p>
</div>
		</div></section>
<section id="text-328" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">bin boysz</h4>
			<div class="textwidget"><p><a href="http://www.binboyz.com"><br />
<img src="https://oliverdailynews.com/biz-page-2/binboyz2.jpg" alt="binboyz" /><br />
</a></p>
</div>
		</div></section>
<section id="text-308" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">button anvil</h4>
			<div class="textwidget"><p><a href=" http://www.ezministorage.ca"><br />
<img src="https://oliverdailynews.com/biz-page-2/buttonanvil.jpg" alt="ez anvil" /><br />
</a></p>
</div>
		</div></section>
<section id="text-24" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Nunes Pottinger</h4>
			<div class="textwidget"><a href="
http://www.nunes-pottinger.com/">
<img src="https://oliverdailynews.com/biz-page-2/NP.gif" alt="nunes-pottinger">
</a>


</div>
		</div></section>
<section id="text-276" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Gerards</h4>
			<div class="textwidget"><a href="http://www.gerardsequipment.com">
<img src="https://oliverdailynews.com/biz-page-2/gerards.jpg"alt="gerards">
</a></div>
		</div></section>
<section id="text-347" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">ag foods</h4>
			<div class="textwidget"><p><a href="http://www.agfoods.com"><br />
<img src="https://www.oliverdailynews.com/biz-page-2/agfoods.jpg" alt="agfoods" /> </a></p>
</div>
		</div></section>
<section id="archives-2" class="widget widget_archive"><div class="widget-wrap"><h4 class="widget-title widgettitle">Archives</h4>
		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://oliverdailynews.com/2021/07/'> July 2021 &nbsp;(8)</option>
	<option value='https://oliverdailynews.com/2021/06/'> June 2021 &nbsp;(141)</option>
	<option value='https://oliverdailynews.com/2021/05/'> May 2021 &nbsp;(176)</option>
	<option value='https://oliverdailynews.com/2021/04/'> April 2021 &nbsp;(160)</option>
	<option value='https://oliverdailynews.com/2021/03/'> March 2021 &nbsp;(143)</option>
	<option value='https://oliverdailynews.com/2021/02/'> February 2021 &nbsp;(140)</option>
	<option value='https://oliverdailynews.com/2021/01/'> January 2021 &nbsp;(136)</option>
	<option value='https://oliverdailynews.com/2020/12/'> December 2020 &nbsp;(200)</option>
	<option value='https://oliverdailynews.com/2020/11/'> November 2020 &nbsp;(158)</option>
	<option value='https://oliverdailynews.com/2020/10/'> October 2020 &nbsp;(159)</option>
	<option value='https://oliverdailynews.com/2020/09/'> September 2020 &nbsp;(172)</option>
	<option value='https://oliverdailynews.com/2020/08/'> August 2020 &nbsp;(180)</option>
	<option value='https://oliverdailynews.com/2020/07/'> July 2020 &nbsp;(155)</option>
	<option value='https://oliverdailynews.com/2020/06/'> June 2020 &nbsp;(163)</option>
	<option value='https://oliverdailynews.com/2020/05/'> May 2020 &nbsp;(190)</option>
	<option value='https://oliverdailynews.com/2020/04/'> April 2020 &nbsp;(182)</option>
	<option value='https://oliverdailynews.com/2020/03/'> March 2020 &nbsp;(164)</option>
	<option value='https://oliverdailynews.com/2020/02/'> February 2020 &nbsp;(161)</option>
	<option value='https://oliverdailynews.com/2020/01/'> January 2020 &nbsp;(129)</option>
	<option value='https://oliverdailynews.com/2019/12/'> December 2019 &nbsp;(179)</option>
	<option value='https://oliverdailynews.com/2019/11/'> November 2019 &nbsp;(176)</option>
	<option value='https://oliverdailynews.com/2019/10/'> October 2019 &nbsp;(203)</option>
	<option value='https://oliverdailynews.com/2019/09/'> September 2019 &nbsp;(175)</option>
	<option value='https://oliverdailynews.com/2019/08/'> August 2019 &nbsp;(232)</option>
	<option value='https://oliverdailynews.com/2019/07/'> July 2019 &nbsp;(204)</option>
	<option value='https://oliverdailynews.com/2019/06/'> June 2019 &nbsp;(245)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>
			</div></section>
                                <section id="recent-posts-3" class="widget widget_recent_entries"><div class="widget-wrap">                <h4 class="widget-title widgettitle">Current Posts</h4>
                <ul>
                                <li><a href="https://oliverdailynews.com/when-is-this-foolishness-going-to-end/" title="When is this &#8220;foolishness&#8221; going to end">When is this &#8220;foolishness&#8221; going to end</a></li>
                                <li><a href="https://oliverdailynews.com/red-dots-tell-the-true-story-of-wildfires/" title="Red dots tell the true story of wildfires">Red dots tell the true story of wildfires</a></li>
                                <li><a href="https://oliverdailynews.com/221126-2/" title="Links and Connections">Links and Connections</a></li>
                                <li><a href="https://oliverdailynews.com/by-paul-eby-6/" title="by Paul Eby">by Paul Eby</a></li>
                                <li><a href="https://oliverdailynews.com/150-years-of-residential-school-vernon-exhibit/" title="150 years of residential schools &#8211; Vernon Exhibit">150 years of residential schools &#8211; Vernon Exhibit</a></li>
                                <li><a href="https://oliverdailynews.com/breakfast-in-a-bag-oliver-style/" title="Breakfast in a bag &#8211; Oliver style">Breakfast in a bag &#8211; Oliver style</a></li>
                                <li><a href="https://oliverdailynews.com/lytton-evacuated/" title="Lytton evacuated">Lytton evacuated</a></li>
                                <li><a href="https://oliverdailynews.com/public-hearing-set-for-new-butcher-shop-on-main-street/" title="Public Hearing set for new butcher shop on Main Street">Public Hearing set for new butcher shop on Main Street</a></li>
                                <li><a href="https://oliverdailynews.com/showers-lightning-heat-wow/" title="Showers? lightning, heat wow">Showers? lightning, heat wow</a></li>
                                <li><a href="https://oliverdailynews.com/school-district-52/" title="School District 53">School District 53</a></li>
                                <li><a href="https://oliverdailynews.com/another-182-bodies-found-in-cranbrook-at-st-eugenes-school/" title="Another 182 bodies found &#8211; in Cranbrook at St. Eugene&#8217;s School">Another 182 bodies found &#8211; in Cranbrook at St. Eugene&#8217;s School</a></li>
                                <li><a href="https://oliverdailynews.com/final-poll/" title="Final poll">Final poll</a></li>
                                <li><a href="https://oliverdailynews.com/covid-stats-2/" title="5 million doses of vaccine &#8220;jabbed&#8221; in BC">5 million doses of vaccine &#8220;jabbed&#8221; in BC</a></li>
                                <li><a href="https://oliverdailynews.com/winners-all-2/" title="Winners all">Winners all</a></li>
                                <li><a href="https://oliverdailynews.com/let-us-talk-about-your-mask/" title="Let us talk about your mask !!">Let us talk about your mask !!</a></li>
                                <li><a href="https://oliverdailynews.com/special-to-odn/" title="Special &#8211; to ODN">Special &#8211; to ODN</a></li>
                                <li><a href="https://oliverdailynews.com/notice-from-olivers-food-bank/" title="Notice from Oliver&#8217;s Food Bank">Notice from Oliver&#8217;s Food Bank</a></li>
                                <li><a href="https://oliverdailynews.com/council-highlights-2/" title="Council highlights">Council highlights</a></li>
                                <li><a href="https://oliverdailynews.com/rcmp-reports/" title="RCMP reports">RCMP reports</a></li>
                                <li><a href="https://oliverdailynews.com/fires-in-the-neighbourhood/" title="Fires in the neighbourhood">Fires in the neighbourhood</a></li>
                                <li><a href="https://oliverdailynews.com/rats-council-to-discuss-today/" title="&#8220;Rats&#8221; !! Council to discuss today">&#8220;Rats&#8221; !! Council to discuss today</a></li>
                                <li><a href="https://oliverdailynews.com/best-i-could-find-for-cool-owl/" title="Best I could find for &#8220;cool&#8221; owl!">Best I could find for &#8220;cool&#8221; owl!</a></li>
                                <li><a href="https://oliverdailynews.com/this-might-cool-you-down/" title="This might cool you down">This might cool you down</a></li>
                                <li><a href="https://oliverdailynews.com/by-julie-martineau-5/" title="by Julie Martineau">by Julie Martineau</a></li>
                                <li><a href="https://oliverdailynews.com/fairly-cool-over-night-18-degrees/" title="Fairly cool over night 18 degrees">Fairly cool over night 18 degrees</a></li>
                                <li><a href="https://oliverdailynews.com/warriors-on-the-loose-churches-burn-to-the-ground/" title="&#8220;Warriors&#8221; on the loose &#8211; churches burn to the ground">&#8220;Warriors&#8221; on the loose &#8211; churches burn to the ground</a></li>
                                <li><a href="https://oliverdailynews.com/fire-activity-in-our-region-very-limited/" title="Fire activity in our region &#8211; very limited">Fire activity in our region &#8211; very limited</a></li>
                                <li><a href="https://oliverdailynews.com/on-the-sunny-side-56/" title="On the Sunny Side">On the Sunny Side</a></li>
                                <li><a href="https://oliverdailynews.com/221059-2/" title="221059">221059</a></li>
                                <li><a href="https://oliverdailynews.com/hot-weather-dome-110-degrees-f-or-43-c/" title="Hot weather dome &#8211; 110 degrees F or 43 C">Hot weather dome &#8211; 110 degrees F or 43 C</a></li>
                                <li><a href="https://oliverdailynews.com/high-profile-offender-arrested-in-oliver/" title="High profile offender arrested in Oliver">High profile offender arrested in Oliver</a></li>
                                <li><a href="https://oliverdailynews.com/thanks-2/" title="Thanks">Thanks</a></li>
                                <li><a href="https://oliverdailynews.com/down-the-aisle-72/" title="Down the aisle">Down the aisle</a></li>
                                <li><a href="https://oliverdailynews.com/oliver-elks-meat-draw-sunday/" title="Oliver Elks &#8211; Meat draw Sunday">Oliver Elks &#8211; Meat draw Sunday</a></li>
                                <li><a href="https://oliverdailynews.com/this-might-cool-you-down-a-bit/" title="This might cool you down a bit">This might cool you down a bit</a></li>
                                <li><a href="https://oliverdailynews.com/by-audrey-macnaughton-25/" title="by Audrey MacNaughton">by Audrey MacNaughton</a></li>
                                <li><a href="https://oliverdailynews.com/st-john-the-baptist/" title="St. John the Baptist">St. John the Baptist</a></li>
                                <li><a href="https://oliverdailynews.com/221030-2/" title="221030">221030</a></li>
                                <li><a href="https://oliverdailynews.com/reaching-the-80-percent-mark/" title="Reaching the 80 percent mark  ??">Reaching the 80 percent mark  ??</a></li>
                                <li><a href="https://oliverdailynews.com/media-release/" title="Media release">Media release</a></li>
                                <li><a href="https://oliverdailynews.com/fairview-cemetery/" title="Fairview Cemetery">Fairview Cemetery</a></li>
                                <li><a href="https://oliverdailynews.com/where-11/" title="Where?">Where?</a></li>
                                <li><a href="https://oliverdailynews.com/heat-wave-cometh/" title="Heat wave cometh">Heat wave cometh</a></li>
                                <li><a href="https://oliverdailynews.com/quote-of-the-week-5/" title="Quote of the week">Quote of the week</a></li>
                                <li><a href="https://oliverdailynews.com/when-is-all-of-this-going-to-stop/" title="When is all of this going to stop?">When is all of this going to stop?</a></li>
                                <li><a href="https://oliverdailynews.com/oh-canada/" title="Oh Canada">Oh Canada</a></li>
                                <li><a href="https://oliverdailynews.com/facts/" title="Facts">Facts</a></li>
                                <li><a href="https://oliverdailynews.com/next-week-thursday/" title="Next week &#8211; Thursday ???">Next week &#8211; Thursday ???</a></li>
                                <li><a href="https://oliverdailynews.com/could-be-showers/" title="Could be showers">Could be showers</a></li>
                                <li><a href="https://oliverdailynews.com/sunday-lowest-case-count-since-august/" title="Sunday &#8211; lowest case count since August">Sunday &#8211; lowest case count since August</a></li>
                                <li><a href="https://oliverdailynews.com/try-this-one-grade-3-1945/" title="Try this one &#8211; grade 3 1945">Try this one &#8211; grade 3 1945</a></li>
                                <li><a href="https://oliverdailynews.com/rcmp-report-2/" title="RCMP report">RCMP report</a></li>
                                <li><a href="https://oliverdailynews.com/but-wont-speculate-on-a-motive-suspicious-fire-at-oib-and-pib/" title="Suspicious fires &#8211; no confirmation on arson &#8211; at PIB and OIB historic churches">Suspicious fires &#8211; no confirmation on arson &#8211; at PIB and OIB historic churches</a></li>
                                <li><a href="https://oliverdailynews.com/my-reach-is-not-that-great/" title="My reach is not that great">My reach is not that great</a></li>
                                <li><a href="https://oliverdailynews.com/congratulations-to-soss-students/" title="Congratulations to SOSS students">Congratulations to SOSS students</a></li>
                                <li><a href="https://oliverdailynews.com/two-church-fire-in-so-one-in-penticton-and-one-in-oliver/" title="Two church fires in SO &#8211; one in Penticton and one in Oliver">Two church fires in SO &#8211; one in Penticton and one in Oliver</a></li>
                                <li><a href="https://oliverdailynews.com/overnight-fire-on-oib-lands/" title="Overnight fire on OIB lands">Overnight fire on OIB lands</a></li>
                                <li><a href="https://oliverdailynews.com/how-about-a-hot-cup-of-coffee-with-phil-at-tucks/" title="How about a hot cup of coffee with Phil at Tuck&#8217;s">How about a hot cup of coffee with Phil at Tuck&#8217;s</a></li>
                                <li><a href="https://oliverdailynews.com/by-bernard-bedard-9/" title="by Bernard Bedard">by Bernard Bedard</a></li>
                                <li><a href="https://oliverdailynews.com/who-what-year-rudy-and-his-teachers/" title="Who? 1945- Rudy and his teachers">Who? 1945- Rudy and his teachers</a></li>
                                <li><a href="https://oliverdailynews.com/decisive-victory/" title="Decisive victory">Decisive victory</a></li>
                                <li><a href="https://oliverdailynews.com/senior-editor-at-the-herald-elected-as-penticton-councillor/" title="Senior editor at the Herald elected as Penticton councillor">Senior editor at the Herald elected as Penticton councillor</a></li>
                                <li><a href="https://oliverdailynews.com/towels-and-trunks/" title="Towels and trunks">Towels and trunks</a></li>
                                <li><a href="https://oliverdailynews.com/220919-2/" title="220919">220919</a></li>
                                <li><a href="https://oliverdailynews.com/on-the-sunny-side-55/" title="On the Sunny Side">On the Sunny Side</a></li>
                                <li><a href="https://oliverdailynews.com/down-the-aisle-71/" title="Down the aisle">Down the aisle</a></li>
                                <li><a href="https://oliverdailynews.com/letter-to-the-editor-29/" title="Letter to the editor">Letter to the editor</a></li>
                                <li><a href="https://oliverdailynews.com/bc-fails-to-break-the-80-percent-vaccine-rate-film-at-eleven/" title="BC fails to break the 80 percent vaccine rate &#8211; film at eleven">BC fails to break the 80 percent vaccine rate &#8211; film at eleven</a></li>
                                <li><a href="https://oliverdailynews.com/highway-to-healing-feature-on-global-okanagan/" title="Highway to Healing feature on Global Okanagan">Highway to Healing feature on Global Okanagan</a></li>
                                <li><a href="https://oliverdailynews.com/rotary-cash-draw/" title="Rotary cash draw">Rotary cash draw</a></li>
                                <li><a href="https://oliverdailynews.com/outstanding/" title="Outstanding">Outstanding</a></li>
                                <li><a href="https://oliverdailynews.com/yup-sounds-good-can-i-take-off-the-mask/" title="Yup &#8211; sounds good  &#8211; can I take off the mask?">Yup &#8211; sounds good  &#8211; can I take off the mask?</a></li>
                                <li><a href="https://oliverdailynews.com/from-the-publisher-2/" title="From the publisher">From the publisher</a></li>
                                <li><a href="https://oliverdailynews.com/sunny-daze-ahead/" title="Sunny Daze Ahead">Sunny Daze Ahead</a></li>
                                <li><a href="https://oliverdailynews.com/220879-2/" title="CKNW icon passes at 92">CKNW icon passes at 92</a></li>
                                <li><a href="https://oliverdailynews.com/220867-2/" title="Delegation &#8211; Oliver Ambassadors and Candidates">Delegation &#8211; Oliver Ambassadors and Candidates</a></li>
                                <li><a href="https://oliverdailynews.com/town-of-oliver-council-briefs-10/" title="Town of Oliver &#8211; council briefs">Town of Oliver &#8211; council briefs</a></li>
                                <li><a href="https://oliverdailynews.com/on-the-board-with-grayson-warn/" title="On the board with Grayson Warn">On the board with Grayson Warn</a></li>
                                <li><a href="https://oliverdailynews.com/canada-report/" title="Canada report">Canada report</a></li>
                                <li><a href="https://oliverdailynews.com/on-the-road-again-rcmp-style/" title="On the road again &#8211; RCMP style">On the road again &#8211; RCMP style</a></li>
                                <li><a href="https://oliverdailynews.com/did-you-enjoy-the-storm/" title="Did you enjoy the storm?">Did you enjoy the storm?</a></li>
                                <li><a href="https://oliverdailynews.com/220843-2/" title="Peeking at the ducks">Peeking at the ducks</a></li>
                                <li><a href="https://oliverdailynews.com/220820-2/" title="Grads &#8211; Oliver and Osoyoos">Grads &#8211; Oliver and Osoyoos</a></li>
                                <li><a href="https://oliverdailynews.com/the-steele-report-49/" title="The Steele report">The Steele report</a></li>
                                <li><a href="https://oliverdailynews.com/220832-2/" title="A simple rose &#8211; in a garden in Oliver">A simple rose &#8211; in a garden in Oliver</a></li>
                                <li><a href="https://oliverdailynews.com/watch-out/" title="Watch out!!!!!!!!!!!!!!!!!!">Watch out!!!!!!!!!!!!!!!!!!</a></li>
                                <li><a href="https://oliverdailynews.com/on-the-sunny-side-54/" title="On the Sunny Side">On the Sunny Side</a></li>
                                <li><a href="https://oliverdailynews.com/down-the-aisle-70/" title="Down the aisle">Down the aisle</a></li>
                                <li><a href="https://oliverdailynews.com/by-david-evans/" title="by David Evans">by David Evans</a></li>
                                <li><a href="https://oliverdailynews.com/no-covid-cash-discount-from-icbc/" title="No covid cash discount from ICBC">No covid cash discount from ICBC</a></li>
                                <li><a href="https://oliverdailynews.com/bridge-repairs-and-upgrade-to-cost-400-t/" title="Bridge repair/upgrade to cost 400 T">Bridge repair/upgrade to cost 400 T</a></li>
                                <li><a href="https://oliverdailynews.com/walk-in-vaccine-clinics-head-out-on-the-road/" title="Walk in vaccine clinics head out on the road">Walk in vaccine clinics head out on the road</a></li>
                                <li><a href="https://oliverdailynews.com/third-gangland-slaying-in-naramata/" title="Third gangland slaying in Naramata">Third gangland slaying in Naramata</a></li>
                                <li><a href="https://oliverdailynews.com/covid-report-3/" title="Covid report">Covid report</a></li>
                                <li><a href="https://oliverdailynews.com/community-support/" title="Community support">Community support</a></li>
                                <li><a href="https://oliverdailynews.com/july-14th/" title="July 14th">July 14th</a></li>
                                <li><a href="https://oliverdailynews.com/lions-roar-for-back-pack-progamme/" title="Lions roar for star fish back pak program&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;.">Lions roar for star fish back pak program&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;.</a></li>
                                <li><a href="https://oliverdailynews.com/tax-time/" title="Tax Time">Tax Time</a></li>
                                <li><a href="https://oliverdailynews.com/ih-medical-health-officer-arrested/" title="IH Medical Health officer &#8211; arrested">IH Medical Health officer &#8211; arrested</a></li>
                                <li><a href="https://oliverdailynews.com/by-interior-health/" title="by Interior Health">by Interior Health</a></li>
                                </ul>
                </div></section>
<section id="calendar-3" class="widget widget_calendar"><div class="widget-wrap"><h4 class="widget-title widgettitle">Find a post by the date</h4>
<div id="calendar_wrap" class="calendar_wrap"><table id="wp-calendar" class="wp-calendar-table">
	<caption>July 2021</caption>
	<thead>
	<tr>
		<th scope="col" title="Sunday">S</th>
		<th scope="col" title="Monday">M</th>
		<th scope="col" title="Tuesday">T</th>
		<th scope="col" title="Wednesday">W</th>
		<th scope="col" title="Thursday">T</th>
		<th scope="col" title="Friday">F</th>
		<th scope="col" title="Saturday">S</th>
	</tr>
	</thead>
	<tbody>
	<tr>
		<td colspan="4" class="pad">&nbsp;</td><td><a href="https://oliverdailynews.com/2021/07/01/" aria-label="Posts published on 1 July 2021">1</a></td><td id="today"><a href="https://oliverdailynews.com/2021/07/02/" aria-label="Posts published on 2 July 2021">2</a></td><td>3</td>
	</tr>
	<tr>
		<td>4</td><td>5</td><td>6</td><td>7</td><td>8</td><td>9</td><td>10</td>
	</tr>
	<tr>
		<td>11</td><td>12</td><td>13</td><td>14</td><td>15</td><td>16</td><td>17</td>
	</tr>
	<tr>
		<td>18</td><td>19</td><td>20</td><td>21</td><td>22</td><td>23</td><td>24</td>
	</tr>
	<tr>
		<td>25</td><td>26</td><td>27</td><td>28</td><td>29</td><td>30</td><td>31</td>
	</tr>
	</tbody>
	</table><nav aria-label="Previous and next months" class="wp-calendar-nav">
		<span class="wp-calendar-nav-prev"><a href="https://oliverdailynews.com/2021/06/">&laquo; Jun</a></span>
		<span class="pad">&nbsp;</span>
		<span class="wp-calendar-nav-next">&nbsp;</span>
	</nav></div></div></section>
</aside></div><aside class="sidebar sidebar-secondary widget-area" role="complementary" aria-label="Secondary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="text-339" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">pappas</h4>
			<div class="textwidget"><p><a href="http://www.pappasfirehallbistro.ca/"><img src="https://oliverdailynews.com/biz-page-2/fotis4square.jpg" alt="bistro" /></a></p>
</div>
		</div></section>
<section id="search-4" class="widget widget_search"><div class="widget-wrap"><h4 class="widget-title widgettitle">SEARCH HERE:</h4>
<form class="search-form" method="get" action="https://oliverdailynews.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="Search ODN" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://oliverdailynews.com/?s={s}" itemprop="target"></form></div></section>
<section id="text-64" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">argon left</h4>
			<div class="textwidget"><a href="
http://www.argonelectrical.ca">
<img src="https://oliverdailynews.com/biz-page-2/newargon.gif" alt="argon">
</a></div>
		</div></section>
<section id="text-344" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">park drive</h4>
			<div class="textwidget"><p>Phone 250.498.2322<br />
<a href="
http://www.parkdrivechurch.ca"><br />
<img src="https://oliverdailynews.com/biz-page-2/parkdrivechurch.jpg" alt="park drive church"><br />
</a></p>
</div>
		</div></section>
<section id="text-220" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Valley Congreg Church</h4>
			<div class="textwidget"><a href="
http://www.valleycongregationalchurch.com/">
<img src="https://oliverdailynews.com/biz-page-2/ednabutton.jpg" alt="valley congregational">
</a>
</div>
		</div></section>
<section id="text-260" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">hwy to healing</h4>
			<div class="textwidget"><a href="
http://www.highwaytohealing.org">
<img src="https://oliverdailynews.com/biz-page-2/hwy3newbutton.jpg" alt="highway">
</a></div>
		</div></section>
<section id="text-248" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">oliverkiwanis.org</h4>
			<div class="textwidget"><a href="http://www.oliverkiwanis.org">
<img src="https://oliverdailynews.com/biz-page-2/kiwanis.jpg" alt="oliverkiwanis" >
</a></div>
		</div></section>
<section id="recent-comments-3" class="widget widget_recent_comments"><div class="widget-wrap"><h4 class="widget-title widgettitle">Comments</h4>
<ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Marilyn Murphy</span> on <a href="https://oliverdailynews.com/school-district-52/comment-page-1/#comment-399684">School District 53</a></li><li class="recentcomments"><span class="comment-author-link">Lynne thompson</span> on <a href="https://oliverdailynews.com/breakfast-in-a-bag-oliver-style/comment-page-1/#comment-399683">Breakfast in a bag &#8211; Oliver style</a></li><li class="recentcomments"><span class="comment-author-link">Keith Urton</span> on <a href="https://oliverdailynews.com/public-hearing-set-for-new-butcher-shop-on-main-street/comment-page-1/#comment-399682">Public Hearing set for new butcher shop on Main Street</a></li><li class="recentcomments"><span class="comment-author-link">Joshua McGinnis</span> on <a href="https://oliverdailynews.com/media-release/comment-page-1/#comment-399680">Media release</a></li><li class="recentcomments"><span class="comment-author-link">Keith Johnson</span> on <a href="https://oliverdailynews.com/public-hearing-set-for-new-butcher-shop-on-main-street/comment-page-1/#comment-399679">Public Hearing set for new butcher shop on Main Street</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn C Tipler</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399678">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Brita Park</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399677">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Heather Frank</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399676">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Michael Richard Guthrie</span> on <a href="https://oliverdailynews.com/another-182-bodies-found-in-cranbrook-at-st-eugenes-school/comment-page-1/#comment-399675">Another 182 bodies found &#8211; in Cranbrook at St. Eugene&#8217;s School</a></li><li class="recentcomments"><span class="comment-author-link">Dorothy Taylor</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399673">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Roger McKay</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399672">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Roy French</span> on <a href="https://oliverdailynews.com/another-182-bodies-found-in-cranbrook-at-st-eugenes-school/comment-page-1/#comment-399671">Another 182 bodies found &#8211; in Cranbrook at St. Eugene&#8217;s School</a></li><li class="recentcomments"><span class="comment-author-link">Richard Simmons Jr.</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399670">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/another-182-bodies-found-in-cranbrook-at-st-eugenes-school/comment-page-1/#comment-399669">Another 182 bodies found &#8211; in Cranbrook at St. Eugene&#8217;s School</a></li><li class="recentcomments"><span class="comment-author-link">Dianna Weichel</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399668">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Rick Knodel</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399666">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399665">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Roger Hall</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399663">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Ian Gibson</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399662">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Larry Maika</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399661">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Gail Barriskill</span> on <a href="https://oliverdailynews.com/special-to-odn/comment-page-1/#comment-399660">Special &#8211; to ODN</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn C Tipler</span> on <a href="https://oliverdailynews.com/rcmp-reports/comment-page-1/#comment-399658">RCMP reports</a></li><li class="recentcomments"><span class="comment-author-link">Keith Johnson</span> on <a href="https://oliverdailynews.com/rcmp-reports/comment-page-1/#comment-399657">RCMP reports</a></li><li class="recentcomments"><span class="comment-author-link">Mary Lou Ellan</span> on <a href="https://oliverdailynews.com/rcmp-reports/comment-page-1/#comment-399655">RCMP reports</a></li><li class="recentcomments"><span class="comment-author-link">pat whalley</span> on <a href="https://oliverdailynews.com/rcmp-reports/comment-page-1/#comment-399654">RCMP reports</a></li><li class="recentcomments"><span class="comment-author-link">joan nunweiler</span> on <a href="https://oliverdailynews.com/rcmp-reports/comment-page-1/#comment-399652">RCMP reports</a></li><li class="recentcomments"><span class="comment-author-link">yvon aka joseph servais</span> on <a href="https://oliverdailynews.com/rats-council-to-discuss-today/comment-page-1/#comment-399650">&#8220;Rats&#8221; !! Council to discuss today</a></li><li class="recentcomments"><span class="comment-author-link">Edwin Dukes</span> on <a href="https://oliverdailynews.com/rcmp-reports/comment-page-1/#comment-399649">RCMP reports</a></li><li class="recentcomments"><span class="comment-author-link">John Chapman</span> on <a href="https://oliverdailynews.com/best-i-could-find-for-cool-owl/comment-page-1/#comment-399648">Best I could find for &#8220;cool&#8221; owl!</a></li><li class="recentcomments"><span class="comment-author-link">Jeremy Cook</span> on <a href="https://oliverdailynews.com/by-julie-martineau-5/comment-page-1/#comment-399647">by Julie Martineau</a></li><li class="recentcomments"><span class="comment-author-link">Lynne Thompson</span> on <a href="https://oliverdailynews.com/rats-council-to-discuss-today/comment-page-1/#comment-399645">&#8220;Rats&#8221; !! Council to discuss today</a></li><li class="recentcomments"><span class="comment-author-link">Mal Bearman</span> on <a href="https://oliverdailynews.com/on-the-sunny-side-56/comment-page-1/#comment-399641">On the Sunny Side</a></li><li class="recentcomments"><span class="comment-author-link">Bill Greer</span> on <a href="https://oliverdailynews.com/by-julie-martineau-5/comment-page-1/#comment-399638">by Julie Martineau</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/thanks-2/comment-page-1/#comment-399636">Thanks</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/high-profile-offender-arrested-in-oliver/comment-page-1/#comment-399635">High profile offender arrested in Oliver</a></li><li class="recentcomments"><span class="comment-author-link">Terry Schafer</span> on <a href="https://oliverdailynews.com/media-release/comment-page-1/#comment-399634">Media release</a></li><li class="recentcomments"><span class="comment-author-link">Eleanor Moyer</span> on <a href="https://oliverdailynews.com/this-might-cool-you-down/comment-page-1/#comment-399633">This might cool you down</a></li><li class="recentcomments"><span class="comment-author-link">Gail Erickson</span> on <a href="https://oliverdailynews.com/this-might-cool-you-down/comment-page-1/#comment-399632">This might cool you down</a></li><li class="recentcomments"><span class="comment-author-link">Heather Frank</span> on <a href="https://oliverdailynews.com/by-audrey-macnaughton-25/comment-page-1/#comment-399630">by Audrey MacNaughton</a></li><li class="recentcomments"><span class="comment-author-link">Phyllis Whitten</span> on <a href="https://oliverdailynews.com/on-the-sunny-side-56/comment-page-1/#comment-399629">On the Sunny Side</a></li><li class="recentcomments"><span class="comment-author-link">Lia Pinske</span> on <a href="https://oliverdailynews.com/on-the-sunny-side-56/comment-page-1/#comment-399628">On the Sunny Side</a></li><li class="recentcomments"><span class="comment-author-link">Dave Evenson</span> on <a href="https://oliverdailynews.com/on-the-sunny-side-56/comment-page-1/#comment-399627">On the Sunny Side</a></li><li class="recentcomments"><span class="comment-author-link">Roger Hall</span> on <a href="https://oliverdailynews.com/media-release/comment-page-1/#comment-399626">Media release</a></li><li class="recentcomments"><span class="comment-author-link">Greg Casorso</span> on <a href="https://oliverdailynews.com/media-release/comment-page-1/#comment-399623">Media release</a></li><li class="recentcomments"><span class="comment-author-link">Lynne thompson</span> on <a href="https://oliverdailynews.com/st-john-the-baptist/comment-page-1/#comment-399622">St. John the Baptist</a></li><li class="recentcomments"><span class="comment-author-link">Joanne Klone</span> on <a href="https://oliverdailynews.com/where-11/comment-page-1/#comment-399618">Where?</a></li><li class="recentcomments"><span class="comment-author-link">Heather Frank</span> on <a href="https://oliverdailynews.com/fairview-cemetery/comment-page-1/#comment-399617">Fairview Cemetery</a></li><li class="recentcomments"><span class="comment-author-link">Kimberly Jones</span> on <a href="https://oliverdailynews.com/this-might-cool-you-down-a-bit/comment-page-1/#comment-399616">This might cool you down a bit</a></li><li class="recentcomments"><span class="comment-author-link">Sylvain Chabot</span> on <a href="https://oliverdailynews.com/st-john-the-baptist/comment-page-1/#comment-399614">St. John the Baptist</a></li><li class="recentcomments"><span class="comment-author-link">Karen Lowden</span> on <a href="https://oliverdailynews.com/this-might-cool-you-down-a-bit/comment-page-1/#comment-399613">This might cool you down a bit</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn C Tipler</span> on <a href="https://oliverdailynews.com/221030-2/comment-page-1/#comment-399608"></a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/my-reach-is-not-that-great/comment-page-1/#comment-399604">My reach is not that great</a></li><li class="recentcomments"><span class="comment-author-link">Frank McLennan</span> on <a href="https://oliverdailynews.com/how-about-a-hot-cup-of-coffee-with-phil-at-tucks/comment-page-1/#comment-399603">How about a hot cup of coffee with Phil at Tuck&#8217;s</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/my-reach-is-not-that-great/comment-page-1/#comment-399598">My reach is not that great</a></li><li class="recentcomments"><span class="comment-author-link">Germain Miller</span> on <a href="https://oliverdailynews.com/how-about-a-hot-cup-of-coffee-with-phil-at-tucks/comment-page-1/#comment-399596">How about a hot cup of coffee with Phil at Tuck&#8217;s</a></li><li class="recentcomments"><span class="comment-author-link">Frank McLennan</span> on <a href="https://oliverdailynews.com/try-this-one-grade-3-1945/comment-page-1/#comment-399595">Try this one &#8211; grade 3 1945</a></li><li class="recentcomments"><span class="comment-author-link">Jack Dean</span> on <a href="https://oliverdailynews.com/my-reach-is-not-that-great/comment-page-1/#comment-399594">My reach is not that great</a></li><li class="recentcomments"><span class="comment-author-link">Margaret Briscall</span> on <a href="https://oliverdailynews.com/who-what-year-rudy-and-his-teachers/comment-page-1/#comment-399592">Who? 1945- Rudy and his teachers</a></li><li class="recentcomments"><span class="comment-author-link">Dorothy Taylor</span> on <a href="https://oliverdailynews.com/but-wont-speculate-on-a-motive-suspicious-fire-at-oib-and-pib/comment-page-1/#comment-399591">Suspicious fires &#8211; no confirmation on arson &#8211; at PIB and OIB historic churches</a></li><li class="recentcomments"><span class="comment-author-link">Linda Isaak</span> on <a href="https://oliverdailynews.com/how-about-a-hot-cup-of-coffee-with-phil-at-tucks/comment-page-1/#comment-399590">How about a hot cup of coffee with Phil at Tuck&#8217;s</a></li><li class="recentcomments"><span class="comment-author-link">Julie Martiniuk</span> on <a href="https://oliverdailynews.com/who-what-year-rudy-and-his-teachers/comment-page-1/#comment-399589">Who? 1945- Rudy and his teachers</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn C Tipler</span> on <a href="https://oliverdailynews.com/by-bernard-bedard-9/comment-page-1/#comment-399585">by Bernard Bedard</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Madge</span> on <a href="https://oliverdailynews.com/letter-to-the-editor-29/comment-page-1/#comment-399584">Letter to the editor</a></li><li class="recentcomments"><span class="comment-author-link">neil seidler</span> on <a href="https://oliverdailynews.com/letter-to-the-editor-29/comment-page-1/#comment-399582">Letter to the editor</a></li><li class="recentcomments"><span class="comment-author-link">Jill McCullum</span> on <a href="https://oliverdailynews.com/letter-to-the-editor-29/comment-page-1/#comment-399579">Letter to the editor</a></li><li class="recentcomments"><span class="comment-author-link">Jill McCullum</span> on <a href="https://oliverdailynews.com/letter-to-the-editor-29/comment-page-1/#comment-399578">Letter to the editor</a></li><li class="recentcomments"><span class="comment-author-link">Sandra Doerksen</span> on <a href="https://oliverdailynews.com/letter-to-the-editor-29/comment-page-1/#comment-399576">Letter to the editor</a></li><li class="recentcomments"><span class="comment-author-link">Keith Johnson</span> on <a href="https://oliverdailynews.com/letter-to-the-editor-29/comment-page-1/#comment-399575">Letter to the editor</a></li><li class="recentcomments"><span class="comment-author-link">Donna Morgan</span> on <a href="https://oliverdailynews.com/yup-sounds-good-can-i-take-off-the-mask/comment-page-1/#comment-399574">Yup &#8211; sounds good  &#8211; can I take off the mask?</a></li><li class="recentcomments"><span class="comment-author-link">Dorothy Taylor</span> on <a href="https://oliverdailynews.com/bc-fails-to-break-the-80-percent-vaccine-rate-film-at-eleven/comment-page-1/#comment-399573">BC fails to break the 80 percent vaccine rate &#8211; film at eleven</a></li><li class="recentcomments"><span class="comment-author-link">Lynne thompson</span> on <a href="https://oliverdailynews.com/bc-fails-to-break-the-80-percent-vaccine-rate-film-at-eleven/comment-page-1/#comment-399572">BC fails to break the 80 percent vaccine rate &#8211; film at eleven</a></li><li class="recentcomments"><span class="comment-author-link">Terry Schafer</span> on <a href="https://oliverdailynews.com/the-steele-report-49/comment-page-1/#comment-399571">The Steele report</a></li><li class="recentcomments"><span class="comment-author-link">Bob firman</span> on <a href="https://oliverdailynews.com/from-the-publisher-2/comment-page-1/#comment-399570">From the publisher</a></li><li class="recentcomments"><span class="comment-author-link">Tanya Martin</span> on <a href="https://oliverdailynews.com/highway-to-healing-feature-on-global-okanagan/comment-page-1/#comment-399569">Highway to Healing feature on Global Okanagan</a></li><li class="recentcomments"><span class="comment-author-link">Brita Park</span> on <a href="https://oliverdailynews.com/outstanding/comment-page-1/#comment-399562">Outstanding</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/from-the-publisher-2/comment-page-1/#comment-399561">From the publisher</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/outstanding/comment-page-1/#comment-399560">Outstanding</a></li><li class="recentcomments"><span class="comment-author-link">Michelle Coates</span> on <a href="https://oliverdailynews.com/yup-sounds-good-can-i-take-off-the-mask/comment-page-1/#comment-399559">Yup &#8211; sounds good  &#8211; can I take off the mask?</a></li><li class="recentcomments"><span class="comment-author-link">Janet Thompson</span> on <a href="https://oliverdailynews.com/from-the-publisher-2/comment-page-1/#comment-399557">From the publisher</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/sunny-daze-ahead/comment-page-1/#comment-399556">Sunny Daze Ahead</a></li><li class="recentcomments"><span class="comment-author-link">Sarah Bedard</span> on <a href="https://oliverdailynews.com/yup-sounds-good-can-i-take-off-the-mask/comment-page-1/#comment-399555">Yup &#8211; sounds good  &#8211; can I take off the mask?</a></li><li class="recentcomments"><span class="comment-author-link">Publisher</span> on <a href="https://oliverdailynews.com/sunny-daze-ahead/comment-page-1/#comment-399554">Sunny Daze Ahead</a></li><li class="recentcomments"><span class="comment-author-link">Lynne Thompson</span> on <a href="https://oliverdailynews.com/sunny-daze-ahead/comment-page-1/#comment-399552">Sunny Daze Ahead</a></li><li class="recentcomments"><span class="comment-author-link">Verna I DeMerchant(Fleming)</span> on <a href="https://oliverdailynews.com/from-the-publisher-2/comment-page-1/#comment-399551">From the publisher</a></li><li class="recentcomments"><span class="comment-author-link">Dorothy Taylor</span> on <a href="https://oliverdailynews.com/from-the-publisher-2/comment-page-1/#comment-399550">From the publisher</a></li><li class="recentcomments"><span class="comment-author-link">Roger Hall</span> on <a href="https://oliverdailynews.com/from-the-publisher-2/comment-page-1/#comment-399549">From the publisher</a></li><li class="recentcomments"><span class="comment-author-link">Lynne Thompson</span> on <a href="https://oliverdailynews.com/from-the-publisher-2/comment-page-1/#comment-399546">From the publisher</a></li><li class="recentcomments"><span class="comment-author-link">Henry Wiebe</span> on <a href="https://oliverdailynews.com/on-the-sunny-side-54/comment-page-1/#comment-399537">On the Sunny Side</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/did-you-enjoy-the-storm/comment-page-1/#comment-399535">Did you enjoy the storm?</a></li><li class="recentcomments"><span class="comment-author-link">bob barker</span> on <a href="https://oliverdailynews.com/220820-2/comment-page-1/#comment-399534">Grads &#8211; Oliver and Osoyoos</a></li><li class="recentcomments"><span class="comment-author-link">George Hall</span> on <a href="https://oliverdailynews.com/clarence-king-went-to-sea-at-13-years-as-a-cadet/comment-page-1/#comment-399533">Clarence King &#8211; went to sea at 13 years as a cadet</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/the-steele-report-49/comment-page-1/#comment-399532">The Steele report</a></li><li class="recentcomments"><span class="comment-author-link">Scott Hesselgrave</span> on <a href="https://oliverdailynews.com/no-covid-cash-discount-from-icbc/comment-page-1/#comment-399528">No covid cash discount from ICBC</a></li><li class="recentcomments"><span class="comment-author-link">Larry Shannon</span> on <a href="https://oliverdailynews.com/by-david-evans/comment-page-1/#comment-399527">by David Evans</a></li><li class="recentcomments"><span class="comment-author-link">Anita Kempf</span> on <a href="https://oliverdailynews.com/by-david-evans/comment-page-1/#comment-399526">by David Evans</a></li><li class="recentcomments"><span class="comment-author-link">George Hall</span> on <a href="https://oliverdailynews.com/clarence-king-went-to-sea-at-13-years-as-a-cadet/comment-page-1/#comment-399525">Clarence King &#8211; went to sea at 13 years as a cadet</a></li><li class="recentcomments"><span class="comment-author-link">Gail Blidook</span> on <a href="https://oliverdailynews.com/220832-2/comment-page-1/#comment-399524">A simple rose &#8211; in a garden in Oliver</a></li><li class="recentcomments"><span class="comment-author-link">Richard Simmons Jr.</span> on <a href="https://oliverdailynews.com/220832-2/comment-page-1/#comment-399521">A simple rose &#8211; in a garden in Oliver</a></li><li class="recentcomments"><span class="comment-author-link">Candy Anders</span> on <a href="https://oliverdailynews.com/on-the-sunny-side-54/comment-page-1/#comment-399519">On the Sunny Side</a></li><li class="recentcomments"><span class="comment-author-link">Maureen Bott</span> on <a href="https://oliverdailynews.com/no-covid-cash-discount-from-icbc/comment-page-1/#comment-399518">No covid cash discount from ICBC</a></li><li class="recentcomments"><span class="comment-author-link">Phyllis Whitten</span> on <a href="https://oliverdailynews.com/on-the-sunny-side-54/comment-page-1/#comment-399516">On the Sunny Side</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/by-david-evans/comment-page-1/#comment-399515">by David Evans</a></li><li class="recentcomments"><span class="comment-author-link">Lee Ann Wilson</span> on <a href="https://oliverdailynews.com/no-covid-cash-discount-from-icbc/comment-page-1/#comment-399514">No covid cash discount from ICBC</a></li><li class="recentcomments"><span class="comment-author-link">Pat Wessel</span> on <a href="https://oliverdailynews.com/walk-in-vaccine-clinics-head-out-on-the-road/comment-page-1/#comment-399513">Walk in vaccine clinics head out on the road</a></li><li class="recentcomments"><span class="comment-author-link">Dave drought</span> on <a href="https://oliverdailynews.com/tax-time/comment-page-1/#comment-399504">Tax Time</a></li><li class="recentcomments"><span class="comment-author-link">Bill Eggert</span> on <a href="https://oliverdailynews.com/tax-time/comment-page-1/#comment-399501">Tax Time</a></li><li class="recentcomments"><span class="comment-author-link">Eleanor Moyer</span> on <a href="https://oliverdailynews.com/by-interior-health/comment-page-1/#comment-399490">by Interior Health</a></li><li class="recentcomments"><span class="comment-author-link">Tracey lapointe</span> on <a href="https://oliverdailynews.com/by-alan-patton/comment-page-1/#comment-399485">by Alan Patton</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/by-alan-patton/comment-page-1/#comment-399484">by Alan Patton</a></li><li class="recentcomments"><span class="comment-author-link">Keith Johnson</span> on <a href="https://oliverdailynews.com/by-alan-patton/comment-page-1/#comment-399483">by Alan Patton</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/220701-2/comment-page-1/#comment-399482">Profile</a></li><li class="recentcomments"><span class="comment-author-link">Mireille Sauvé</span> on <a href="https://oliverdailynews.com/by-alan-patton/comment-page-1/#comment-399481">by Alan Patton</a></li><li class="recentcomments"><span class="comment-author-link">Keith Johnson</span> on <a href="https://oliverdailynews.com/70-percent-of-people-in-bc-vaccinated-can-i-take-my-mask-off/comment-page-1/#comment-399479">70 percent of people in BC vaccinated &#8211; can I take my mask off?</a></li><li class="recentcomments"><span class="comment-author-link">Deborah Ham</span> on <a href="https://oliverdailynews.com/70-percent-of-people-in-bc-vaccinated-can-i-take-my-mask-off/comment-page-1/#comment-399473">70 percent of people in BC vaccinated &#8211; can I take my mask off?</a></li><li class="recentcomments"><span class="comment-author-link">Gail Blidook</span> on <a href="https://oliverdailynews.com/by-audrey-macnaughton-24/comment-page-1/#comment-399471">by Audrey MacNaughton</a></li><li class="recentcomments"><span class="comment-author-link">David Flegel</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399469">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/letter-to-the-editor-28/comment-page-1/#comment-399468">Letter to the editor</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/bedroom-cleanup-at-the-bridge/comment-page-1/#comment-399465">Bedroom cleanup at the Bridge</a></li><li class="recentcomments"><span class="comment-author-link">Lynne Thompson</span> on <a href="https://oliverdailynews.com/70-percent-of-people-in-bc-vaccinated-can-i-take-my-mask-off/comment-page-1/#comment-399464">70 percent of people in BC vaccinated &#8211; can I take my mask off?</a></li><li class="recentcomments"><span class="comment-author-link">Lynne Thompson</span> on <a href="https://oliverdailynews.com/wet-maybe/comment-page-1/#comment-399463">Wet? &#8211; maybe</a></li><li class="recentcomments"><span class="comment-author-link">Mireille Sauvé</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399461">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/bedroom-cleanup-at-the-bridge/comment-page-1/#comment-399460">Bedroom cleanup at the Bridge</a></li><li class="recentcomments"><span class="comment-author-link">Jovia Barnett</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399459">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Keith Johnson</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399458">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Stan Marshall</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399457">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Stan Marshall</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399456">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Jessica Murphy</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399454">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Jessica Murphy</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399453">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Merrill Bjerkan</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399452">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Richard Simmons Jr.</span> on <a href="https://oliverdailynews.com/wet-maybe/comment-page-1/#comment-399450">Wet? &#8211; maybe</a></li><li class="recentcomments"><span class="comment-author-link">Jovia Barnett</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399449">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Kevin Tomlin</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399448">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Shannon Dillabough</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399447">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Kevin tomlin</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399444">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Wes Mytruk</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399443">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Stuart Dickinson</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399442">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Stuart Dickinson</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399441">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Tara Strong</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399440">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Simon Gillett</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399438">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">theresa mccabe</span> on <a href="https://oliverdailynews.com/down-the-aisle-69/comment-page-1/#comment-399435">Down the aisle</a></li><li class="recentcomments"><span class="comment-author-link">bill eggert</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399434">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Kyle Campbell</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399433">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Al Hudec</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399432">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Terry</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399430">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Chad Collington</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399429">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/bedroom-cleanup-at-the-bridge/comment-page-1/#comment-399426">Bedroom cleanup at the Bridge</a></li><li class="recentcomments"><span class="comment-author-link">Bob Barker</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-12/comment-page-1/#comment-399425">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Joyce Bunge</span> on <a href="https://oliverdailynews.com/remains-of-215-children-found-near-kamloops/comment-page-1/#comment-399424">Remains of 215 children found near Kamloops</a></li><li class="recentcomments"><span class="comment-author-link">Joyce Bunge</span> on <a href="https://oliverdailynews.com/bedroom-cleanup-at-the-bridge/comment-page-1/#comment-399423">Bedroom cleanup at the Bridge</a></li><li class="recentcomments"><span class="comment-author-link">Maureen Doerr</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399420">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Bill Greer</span> on <a href="https://oliverdailynews.com/by-audrey-macnaughton-24/comment-page-1/#comment-399419">by Audrey MacNaughton</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn C Tipler</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399416">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Grant MacPherson</span> on <a href="https://oliverdailynews.com/vaccine-update/comment-page-1/#comment-399413">Vaccine update</a></li><li class="recentcomments"><span class="comment-author-link">John Kiss</span> on <a href="https://oliverdailynews.com/by-audrey-macnaughton-24/comment-page-1/#comment-399411">by Audrey MacNaughton</a></li><li class="recentcomments"><span class="comment-author-link">Jack Dean</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399410">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">DOROTHY HOFMANN</span> on <a href="https://oliverdailynews.com/by-audrey-macnaughton-24/comment-page-1/#comment-399409">by Audrey MacNaughton</a></li><li class="recentcomments"><span class="comment-author-link">Fred Steele</span> on <a href="https://oliverdailynews.com/the-steele-report-48/comment-page-1/#comment-399408">The Steele report</a></li><li class="recentcomments"><span class="comment-author-link">Keith Johnson</span> on <a href="https://oliverdailynews.com/the-steele-report-48/comment-page-1/#comment-399407">The Steele report</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/the-steele-report-48/comment-page-1/#comment-399406">The Steele report</a></li><li class="recentcomments"><span class="comment-author-link">Adrienne Cleave</span> on <a href="https://oliverdailynews.com/the-steele-report-48/comment-page-1/#comment-399404">The Steele report</a></li><li class="recentcomments"><span class="comment-author-link">Lesli Malanchuk</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399403">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399400">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Gail Blidook (Skelton)</span> on <a href="https://oliverdailynews.com/220562-2/comment-page-1/#comment-399399">In the beginning&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;.</a></li><li class="recentcomments"><span class="comment-author-link">Gail Blidook</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399398">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Dee Pescada</span> on <a href="https://oliverdailynews.com/hello-interior-health-i-am-sorry-we-do-not-know-what-we-are-doing/comment-page-1/#comment-399393">Hello &#8211; Interior Health &#8211; &#8221; I am sorry we do not know what we are doing&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Roger McKay</span> on <a href="https://oliverdailynews.com/220562-2/comment-page-1/#comment-399391">In the beginning&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;.</a></li><li class="recentcomments"><span class="comment-author-link">Kay Rotheisler</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399390">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Keith Johnson</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399389">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/push-a-broom-drop-a-rock/comment-page-1/#comment-399385">Push a broom &#8211; drop a rock</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/bedroom-cleanup-at-the-bridge/comment-page-1/#comment-399384">Bedroom cleanup at the Bridge</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399383">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/push-a-broom-drop-a-rock/comment-page-1/#comment-399382">Push a broom &#8211; drop a rock</a></li><li class="recentcomments"><span class="comment-author-link">Sheryll Matheson</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399381">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Debbie Lee</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399380">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Gail Blidook</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399378">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Richard Simmons Jr.</span> on <a href="https://oliverdailynews.com/by-pat-whalley-72/comment-page-1/#comment-399377">by Pat Whalley</a></li><li class="recentcomments"><span class="comment-author-link">Deborah Ham</span> on <a href="https://oliverdailynews.com/push-a-broom-drop-a-rock/comment-page-1/#comment-399376">Push a broom &#8211; drop a rock</a></li><li class="recentcomments"><span class="comment-author-link">Gail Blidook</span> on <a href="https://oliverdailynews.com/220562-2/comment-page-1/#comment-399374">In the beginning&#8230;&#8230;&#8230;&#8230;&#8230;&#8230;.</a></li><li class="recentcomments"><span class="comment-author-link">Barbara Burns</span> on <a href="https://oliverdailynews.com/hello-interior-health-i-am-sorry-we-do-not-know-what-we-are-doing/comment-page-1/#comment-399373">Hello &#8211; Interior Health &#8211; &#8221; I am sorry we do not know what we are doing&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Bonnie Dancey</span> on <a href="https://oliverdailynews.com/hello-interior-health-i-am-sorry-we-do-not-know-what-we-are-doing/comment-page-1/#comment-399372">Hello &#8211; Interior Health &#8211; &#8221; I am sorry we do not know what we are doing&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/hello-interior-health-i-am-sorry-we-do-not-know-what-we-are-doing/comment-page-1/#comment-399371">Hello &#8211; Interior Health &#8211; &#8221; I am sorry we do not know what we are doing&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Joyce Kuzyk</span> on <a href="https://oliverdailynews.com/push-a-broom-drop-a-rock/comment-page-1/#comment-399370">Push a broom &#8211; drop a rock</a></li><li class="recentcomments"><span class="comment-author-link">Helene Godin</span> on <a href="https://oliverdailynews.com/hello-interior-health-i-am-sorry-we-do-not-know-what-we-are-doing/comment-page-1/#comment-399369">Hello &#8211; Interior Health &#8211; &#8221; I am sorry we do not know what we are doing&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Jan Heidt</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399367">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Wayne Danbrook</span> on <a href="https://oliverdailynews.com/remains-of-215-children-found-near-kamloops/comment-page-1/#comment-399365">Remains of 215 children found near Kamloops</a></li><li class="recentcomments"><span class="comment-author-link">Joan Skelton</span> on <a href="https://oliverdailynews.com/by-jessica-murphy-11/comment-page-1/#comment-399361">by Jessica Murphy</a></li><li class="recentcomments"><span class="comment-author-link">Shirley Stuible</span> on <a href="https://oliverdailynews.com/remains-of-215-children-found-near-kamloops/comment-page-1/#comment-399359">Remains of 215 children found near Kamloops</a></li><li class="recentcomments"><span class="comment-author-link">David Brooks</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399358">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Karen and Gary Brown</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399354">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Joyce Bunge</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399350">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Jennifer Martison</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399349">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399348">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Grant MacPherson</span> on <a href="https://oliverdailynews.com/are-covid-numbers-rising-in-the-southern-okanagan/comment-page-1/#comment-399347">Are Covid numbers rising in the Southern Okanagan?</a></li><li class="recentcomments"><span class="comment-author-link">Al Hudec</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399345">Kontentious Kitchen + Updated</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/rcmp-report/comment-page-1/#comment-399344">RCMP report</a></li><li class="recentcomments"><span class="comment-author-link">Pat Hampson</span> on <a href="https://oliverdailynews.com/remains-of-215-children-found-near-kamloops/comment-page-1/#comment-399339">Remains of 215 children found near Kamloops</a></li><li class="recentcomments"><span class="comment-author-link">Michael Richard Guthrie</span> on <a href="https://oliverdailynews.com/remains-of-215-children-found-near-kamloops/comment-page-1/#comment-399338">Remains of 215 children found near Kamloops</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/remains-of-215-children-found-near-kamloops/comment-page-1/#comment-399337">Remains of 215 children found near Kamloops</a></li><li class="recentcomments"><span class="comment-author-link">Roger McKay</span> on <a href="https://oliverdailynews.com/remains-of-215-children-found-near-kamloops/comment-page-1/#comment-399336">Remains of 215 children found near Kamloops</a></li><li class="recentcomments"><span class="comment-author-link">Carolyn Tipler</span> on <a href="https://oliverdailynews.com/kontentious-kitchen/comment-page-1/#comment-399334">Kontentious Kitchen + Updated</a></li></ul></div></section>
<section id="text-177" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">The one you turn to</h4>
			<div class="textwidget"><div style="text-align:center;">
<p>Submit your banner photos, news items or contact Publisher  <a href="mailto:oliverdailynews@gmail.com"></p>
<p>oliverdailynews at gmail.com</a></p>
<p>ODN is published daily</p>
<p>Mailing Address:<br />
PO Box 686 Oliver, B.C., V0H 1T0</p>
<p>No phone contact<br />
No downtown office location</p>
</div>
		</div></section>
</aside></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2021</p></div></footer></div><a rel="nofollow" style="display:none;" href="https://oliverdailynews.com/?blackhole=9f7df5e469" title="Do NOT follow this link or you will be banned from the site!">Oliver Daily News</a>
<script type='text/javascript'>jQuery(document).ready(function($) {$(".flexslider").flexslider({controlsContainer: "#genesis-responsive-slider",animation: "fade",directionNav: 0,controlNav: 0,animationDuration: 1000,slideshowSpeed: 8000    });  });</script><style type="text/css" media="screen"> #simple-social-icons-2 ul li a, #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus { background-color: #f6f5f2 !important; border-radius: 3px; color: #aaaaaa !important; border: 0px #ffffff solid !important; font-size: 18px; padding: 9px; }  #simple-social-icons-2 ul li a:hover, #simple-social-icons-2 ul li a:focus { background-color: #000000 !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-2 ul li a:focus { outline: 1px dotted #000000 !important; }</style><button id="responsive-menu-button"  tabindex="1"
        class="responsive-menu-button responsive-menu-boring
        "
        type="button"
        aria-label="Menu">

    
    <span class="responsive-menu-box">
        <span class="responsive-menu-inner"></span>
    </span>

            <span class="responsive-menu-label responsive-menu-label-bottom">
            <span class="responsive-menu-button-text">Menu</span>
                    </span>
    </button><div id="responsive-menu-container" class="slide-left">
    <div id="responsive-menu-wrapper" role="navigation" aria-label="mobile-menu">
                                                                                    <ul id="responsive-menu" role="menubar" aria-label="" ><li id="responsive-menu-item-106043" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-home responsive-menu-item"  role="none"><a class="responsive-menu-item-link" href="https://oliverdailynews.com/#recent-comments-3" tabindex="1" role="menuitem" itemprop="url">Recent Comments</a></li><li id="responsive-menu-item-138586" class=" menu-item menu-item-type-custom menu-item-object-custom menu-item-home responsive-menu-item"  role="none"><a class="responsive-menu-item-link" href="https://oliverdailynews.com/#recent-posts-3" tabindex="1" role="menuitem" itemprop="url">Current Posts</a></li><li class="right search"><form class="search-form" method="get" action="https://oliverdailynews.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><input class="search-form-input" type="search" name="s" id="searchform-3" placeholder="Search ODN" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://oliverdailynews.com/?s={s}" itemprop="target"></form></li><li class="right date">July 2, 2021</li></ul>                                                <div id="responsive-menu-search-box">
    <form action="https://oliverdailynews.com" class="responsive-menu-search-form" role="search">
        <input type="search" name="s" title="Search" tabindex="1"
               placeholder="Search"
               class="responsive-menu-search-box">
    </form>
</div>                                                <div id="responsive-menu-additional-content"></div>                        </div>
</div>
<script type='text/javascript' id='wp-polls-js-extra'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/oliverdailynews.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://oliverdailynews.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.6' id='wp-polls-js'></script>
<script type='text/javascript' src='https://oliverdailynews.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://oliverdailynews.com/wp-content/plugins/genesis-responsive-slider/assets/js/jquery.flexslider.js?ver=1.0.1' id='flexslider-js'></script>
<script type='text/javascript' src='https://oliverdailynews.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script>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</script></body></html>
